Düşeyara’da Gelen #YOK Hatası Yerine 0 veya Başka Bir İfade Yazdırmak


Düşeyara işlevini kullandığınız zaman veri bulunamadığı zaman #YOK hatası ile karşılaşırsınız.

Bazı durumlarda #YOK hatası yerine farklı bir değer yazdırma durumunda EĞER ve EHATALISA
işlevlerini DÜŞEYARA ile birlikte kullanmamız gerekir.

örneğin;

=DÜŞEYARA(G3;$A$3:$C$609;2;0) formülü G3 hücresindeki değeri A3:C609 arasında aratır ve
veri bulamadığı yerde #YOK hatasına düşürür.  Bu da sıralama yaparken, ortalama alırken sıkıntılar yaratabilir.
Aynı formülü;

=EĞER(EHATALIYSA(DÜŞEYARA(G3;$A$3:$C$609;2;0)=DOĞRU);0;DÜŞEYARA(G3;$A$3:$C$609;2;0))

şeklinde kullanırsak, #YOK hatası gelen yerlere 0 (sıfır) ifadesi gelir.

Burada 0 yazan yere farklı bir değer de yazdırılabilir.

 

Youtube kanalımızda bulunan 400’dan fazla excel videosu ile Excel programını öğrenebilirsiniz.  Ücretsiz olarak öğrenebileceğiniz Excel sayesinde Excel eğitimlerinizi tamamlayabilirsiniz.

http://www.youtube.com/bagciomer 

adresine tıkladığınızda karşınıza gelen Excel eğitimlerini izleyerek, Excel konusundaki eksikliklerinizi giderebilirsiniz.

Youtube kanalımızdaki Ücretsiz eğitim videolarımızdan farklı olarak Online Excel eğitimlerimiz ile İleri Excel kullanımı öğrenebilirsiniz. Hemen Excel programını öğrenmeye başlamak içinhttp://www.vidoport.com adresine üye olur.

vidoport.com’da 300’den fazla konularına göre ayrılmış Excel eğitim videoları’nı örnek dosyaları indirerek, Excel eğitimlerinizi anlatılan dosya üzerinden çalışmayı sağlarsınız. Tüm konuları tamamladığınızda Başarı Belgenizi alabilirsiniz.

Online Excel eğitimleri için http://www.vidoport.com adresini ziyaret etmenizi öneririm.

About Excel, İleri Excel ve Ofis Eğitmeni - Yazar Ömer BAĞCI

vidoport.com'da Eğitmen İleri Düzey Excel 2016 ve Bilgisayarın B'si kitaplarının yazarı. Kurumsal İleri Düzey Excel eğitimleri ve Excel raporlama eğitimleri alanlarında çalışıyorum.
Bu yazı Genel Excel ve diğer konular içinde yayınlandı ve , , , , , olarak etiketlendi. Kalıcı bağlantıyı yer imlerinize ekleyin.

6 Responses to Düşeyara’da Gelen #YOK Hatası Yerine 0 veya Başka Bir İfade Yazdırmak

  1. Alper Ziya NAMLI dedi ki:

    Merhaba Ömer bey;

    Kitabınızı aldım Kitapsan’dan ve internet üzerinden de sık sık araştırıyorum sizin notlarınızı. Çok çok işe yarayan bir kitap ve web sitesi hazırlamışsınız. Emekleriniz ve bilgilerinize sağlık. Çok teşekkür eder, saygılarımı sunarım. İyi çalışmalar.

  2. emre dedi ki:

    Hocam eline emeğine sağlık

  3. ismail dedi ki:

    BAZI SİTELERDE BULDUĞUM CEVAPLAR HATA VERDİ. AMA PAYLAŞACAĞIM ŞEKİLDE YAZARSANIZ HATA VERMİYOR =EĞERHATA(DÜŞEYARA(A1;Sayfa2!$A$1:$B$22;2;YANLIŞ);0) GÖRDÜĞÜNÜZ GİBİ SADECE DÜŞEY ARA FORMÜLÜNÜN ÖNÜNE EĞERHAT, VE SONUNADA 0 (SIFIR) YAZARSANIZ SORUNSUZCA ÇALIŞIYOR 0 (SIFIR) YERİNE “” KOYARSANIZ HÜCRE KARŞINIZA BOŞ OLARAK GELİYOR İYİ ÇALIŞMALAR

  4. hy dedi ki:

    teşekkürler @İsmail bey verdiğiniz bilgi çok işime yaradı..

  5. Yilmaz dedi ki:

    iyi günler ismail bey EĞER(A2=”#YOK”;”0″) formulü nasıl yazılır.
    =EĞER(AC2=”kaydı”;”0″;EĞER(AC2=”YOK”;”0″;EĞER(AC2=”Ulaşılamadı”;”0″;EĞER(AC2=”1 Ay Ayık”;”1″;EĞER(AC2=”3 Ay Ayık”;”3″;EĞER(AC2=”6 Ay Ayık”;”6″;EĞER(AC2=”9 Ay Ayık”;”9″;EĞER(AC2=”12 Ay Ayık”;”12″;EĞER(AC2=”15 Ay Ayık”;”15″;EĞER(AC2=”18 Ay Ayık”;”18″;EĞER(AC2=”21 Ay Ayık”;”21″;EĞER(AC2=”24 Ay Ayık”;”24″)))))))))))) şeklinde içiçe eğer fonksiyonu yazıyordum ama #Yok bölümler var sutunda onları sıfıra dönüştürmek istiyorum. Nasıl yapabilir.
    Yardım ederseniz çok mutlu olurum. Şimdiden çok teşekkür ederim.

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google fotoğrafı

Google hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.