Düşeyara’da Gelen #YOK Hatası Yerine 0 veya Başka Bir İfade Yazdırmak


Düşeyara işlevini kullandığınız zaman veri bulunamadığı zaman #YOK hatası ile karşılaşırsınız.

Bazı durumlarda #YOK hatası yerine farklı bir değer yazdırma durumunda EĞERHATA İşlevini kullanmanız gerekir. Örneğin;

=DÜŞEYARA(G3;$A$3:$C$609;2;0) formülü G3 hücresindeki değeri A3:C609 arasında aratır ve veri bulamadığı yerde #YOK hatasına düşürür. Bu da sıralama yaparken, ortalama alırken sıkıntılar yaratabilir.
Aynı formülü;

=EĞERHATA(DÜŞEYARA(G3;$A$3:$C$609;2;0);0)

şeklinde kullanırsak, #YOK hatası gelen yerlere 0 (sıfır) ifadesi gelir.

Burada 0 yazan yere farklı bir değer de yazdırılabilir.

Bknz. Düşeyara işlevi ve kullanım eğitim videoları

Reklamlar

About İleri Düzey Excel ve Ofis Eğitmeni - Yazar Ömer BAĞCI

vidoport.com'da Eğitmen İleri Düzey Excel 2016 ve Bilgisayarın B'si kitaplarının yazarı. Kurumsal ve Bireysel Excel Eğitimleri veriyor..
Bu yazı Genel içinde yayınlandı ve , , , , , , , olarak etiketlendi. Kalıcı bağlantıyı yer imlerinize ekleyin.

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap / Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap / Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap / Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap / Değiştir )

Connecting to %s